Bookmark and Share

Author Topic: Requires: Win7/Vista/XP  (Read 262 times)

0 Members and 1 Guest are viewing this topic.

Offline Falconldo

  • PcWinTech Jr. Member
  • Join Date: Sep 2017
  • Posts: 1
  • Location: Missouri Ozark Mountains
  • Karma: 0
  • Smart enough to realize how ignorant I am...
Requires: Win7/Vista/XP
« on: September 22, 2017, 06:11:41 PM »
Hi Shane, new member... love both of your sites. I have a specific question [1] and a more general one [2] on the same topic. Here goes... [1] Preparing to download 'Drive Speedometer' to use on my Windows 10 Pro 64 bit box, and then on 'Download Geeks' I notice that it "Requires: Win7/Vista/XP". NOT the first time I have come across this situation over the years. Will the Program work on my system?  And [2] What risks does someone take trying to install and use a program that doesn't list my OS, only earlier ones? Is there ever a case with today's machines and OS' that you can damage your system? Just curious. Thanks for all the great stuff you do!   :smiley:

PcWinTech.com Forums

Requires: Win7/Vista/XP
« on: September 22, 2017, 06:11:41 PM »

 

email