Author Topic: [Resolved] Port forwarding fails in all Ubiquiti routers.  (Read 14545 times)

0 Members and 1 Guest are viewing this topic.

Offline MerolaC

  • PcWinTech Member
  • *
  • Join Date: Jan 2015
  • Posts: 7
  • Karma: 0
[Resolved] Port forwarding fails in all Ubiquiti routers.
« on: January 01, 2015, 01:19:44 PM »
Hello.
I have been trying this app for a long time now and it works great!
Thanks for it!

I do have a problem, though. Port forwarding/View/Remove in Ubiquiti routers (Nanostation M2, M5 and Loco M5) fails when it arrives at the Network.cgi page.
Latest firmware (Firmware Version: XM.v5.5.10 )

Code: [Select]
Step 01. nav("")
(Successful) (http://10.22.22.1/)
--------------------------------------
Step 02. set_username("username")
(Successful)
--------------------------------------
Step 03. set_password("password")
(Successful)
--------------------------------------
Step 04. click_button("Login")
(Successful)
--------------------------------------
Step 05. nav("network.cgi")
(Successful) (http://10.22.22.1/network.cgi)
--------------------------------------
Step 06. click_button("port_forward_configure")
(Failed - Object Not Found)

Can the script be updated?
And if so, what should I post here so you can update it?

Thanks a lot in advance.

Best regards
MerolaC

BTW, Happy New Year! :D
« Last Edit: January 05, 2015, 07:39:16 PM by MerolaC »

PcWinTech.com Forums

[Resolved] Port forwarding fails in all Ubiquiti routers.
« on: January 01, 2015, 01:19:44 PM »

Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,846
  • Location: USA
  • Karma: 523
  • "Knowledge should be shared not hidden."
Re: Port forwarding fails in all Ubiquiti routers.
« Reply #1 on: January 02, 2015, 04:27:24 PM »
Looks like I just need to update the script :-)

Post a screen shot of the program when it tries to update the router so I can see exactly where it is at when it fails.

Shane
(My weekends belong to my wife and kids, I will try my best to answer all posts daily during the work week)

(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com

Offline MerolaC

  • PcWinTech Member
  • *
  • Join Date: Jan 2015
  • Posts: 7
  • Karma: 0
Re: Port forwarding fails in all Ubiquiti routers.
« Reply #2 on: January 03, 2015, 05:44:42 AM »
Hello Shane.
I have attached the screenshot you requested.

Thank you for your time!

Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,846
  • Location: USA
  • Karma: 523
  • "Knowledge should be shared not hidden."
Re: Port forwarding fails in all Ubiquiti routers.
« Reply #3 on: January 05, 2015, 05:40:05 PM »
Ok lets see if the rest of the script has any trouble. Enable debug mode under the advanced menu. Then you will be able to control when the program goes to the next step in the script.

When it gets to the steps that fails go ahead and click on the port forwarding button in the page for it and then have it continue, this way we can see if any other steps fail for it as well :wink:

Shane
(My weekends belong to my wife and kids, I will try my best to answer all posts daily during the work week)

(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com

Offline MerolaC

  • PcWinTech Member
  • *
  • Join Date: Jan 2015
  • Posts: 7
  • Karma: 0
Re: Port forwarding fails in all Ubiquiti routers.
« Reply #4 on: January 05, 2015, 06:01:11 PM »
Hello, Shane.

Yes, it sadly, failed

Pic attached.

Thanks for the support!

Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,846
  • Location: USA
  • Karma: 523
  • "Knowledge should be shared not hidden."
Re: Port forwarding fails in all Ubiquiti routers.
« Reply #5 on: January 05, 2015, 06:46:19 PM »
Looks like I need to look at it so I can update the script, shoot me an email and I will connect to you and get it working. I will be online for a bit :-)

my email is shane  @ pcwintech.com

Shane
(My weekends belong to my wife and kids, I will try my best to answer all posts daily during the work week)

(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com

Offline MerolaC

  • PcWinTech Member
  • *
  • Join Date: Jan 2015
  • Posts: 7
  • Karma: 0
Re: Port forwarding fails in all Ubiquiti routers.
« Reply #6 on: January 05, 2015, 07:38:52 PM »
Excellent!
This man is a legend!

He connected to me with TeamViewer and did all the work remotely. Fast and simple.
Awesome!
Script was added now to SPF.

Thanks, Shane!

This can be closed now.

Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,846
  • Location: USA
  • Karma: 523
  • "Knowledge should be shared not hidden."
Re: [Resolved] Port forwarding fails in all Ubiquiti routers.
« Reply #7 on: January 05, 2015, 07:41:22 PM »
Happy to help :-)

Locking thread.

Shane
(My weekends belong to my wife and kids, I will try my best to answer all posts daily during the work week)

(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com

PcWinTech.com Forums

Re: [Resolved] Port forwarding fails in all Ubiquiti routers.
« Reply #7 on: January 05, 2015, 07:41:22 PM »