Author Topic: Netgear D6300 Add Custom Service Failed  (Read 5571 times)

0 Members and 1 Guest are viewing this topic.

Offline hindle010

  • PcWinTech Jr. Member
  • Join Date: Feb 2014
  • Posts: 3
  • Karma: 0
Netgear D6300 Add Custom Service Failed
« on: February 13, 2014, 08:24:52 PM »
Hi,
I've attempted to run the script to update the router with the port forwarding entry,
But when it gets to step 06. click_button("Add Custom Service") it returns (Failed - Object Not Found)

I've attached a screenshot of the error and I've also uploaded screenshots of my router using your capture tool

Thanks for your help

PcWinTech.com Forums

Netgear D6300 Add Custom Service Failed
« on: February 13, 2014, 08:24:52 PM »

Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,846
  • Location: USA
  • Karma: 523
  • "Knowledge should be shared not hidden."
Re: Netgear D6300 Add Custom Service Failed
« Reply #1 on: February 14, 2014, 03:22:39 AM »
Post a screen shot of the main page in your router for me, that will let me see the model and the firmware version and I can compare it to the one I made the script for :-)

Shane
(My weekends belong to my wife and kids, I will try my best to answer all posts daily during the work week)

(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com

Offline hindle010

  • PcWinTech Jr. Member
  • Join Date: Feb 2014
  • Posts: 3
  • Karma: 0
Re: Netgear D6300 Add Custom Service Failed
« Reply #2 on: February 15, 2014, 01:06:43 AM »
Thanks Shane,

Attached is a screenshot of the main page

« Last Edit: February 15, 2014, 06:41:02 PM by hindle010 »

Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,846
  • Location: USA
  • Karma: 523
  • "Knowledge should be shared not hidden."
Re: Netgear D6300 Add Custom Service Failed
« Reply #3 on: February 17, 2014, 10:30:00 AM »
Looks like the router doesnt like the frame I had set in the script. Update the router database in the program to get the new script and see how it goes for you now :wink:

Shane
(My weekends belong to my wife and kids, I will try my best to answer all posts daily during the work week)

(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com

Offline hindle010

  • PcWinTech Jr. Member
  • Join Date: Feb 2014
  • Posts: 3
  • Karma: 0
Re: Netgear D6300 Add Custom Service Failed
« Reply #4 on: February 17, 2014, 06:56:36 PM »
Thanks Shane,
The script seem to complete this time but still faced a number of errors

Running Script From Database For Selected Router
-----------------------------------------------------------------------
Step 01. nav_first_only("")
(Successful) (http://192.168.0.1/)
--------------------------------------
Step 02. nav("FW_forward.htm")
(Successful) (http://192.168.0.1/FW_forward.htm)
--------------------------------------
Step 03. check_if_name_exists("")
--------------------------------------
Step 04. click_button("Add Custom Service")
(Failed - Object Not Found)
--------------------------------------
Step 05. set_name("userdefined")
(Failed - Object Not Found)
--------------------------------------
Step 06. set_type_choices("TCP|UDP|TCP/UDP")
--------------------------------------
Step 07. set_combobox("protocol")
(Failed - Object Not Found)
--------------------------------------
Step 08. set_start_port("portstart")
(Failed - Object Not Found)
--------------------------------------
Step 09. set_stop_port("portend")
(Failed - Object Not Found)
--------------------------------------
Step 10. click_button("Apply")
(Successful)
--------------------------------------
Step 11. nav("FW_forward.htm")
(Successful) (http://192.168.0.1/FW_forward.htm)
--------------------------------------
Step 12. click_button("inadd")
(Successful)
--------------------------------------
Step 13. set_combobox_name("service_list")
(Failed - Object Not Found)
--------------------------------------
Step 14. set_combobox_custom("fwin_action,0,ALLOW always")
(Successful)
--------------------------------------
Step 15. set_ip1("lan_start_ip1")
(Successful)
--------------------------------------
Step 16. set_ip2("lan_start_ip2")
(Successful)
--------------------------------------
Step 17. set_ip3("lan_start_ip3")
(Successful)
--------------------------------------
Step 18. set_ip4("lan_start_ip4")
(Successful)
--------------------------------------
Step 19. set_combobox_custom("fwin_waniptype,0,Any")
(Successful)
--------------------------------------
Step 20. click_button("Apply")
(Successful)
--------------------------------------
Step 21. click_button("apply")
(Successful)
--------------------------------------
-----------------------------------------------------------------------

Finished Adding uTorrent01


-------------------DONE! (All Commands Finished)-------------------


Thanks

Appreciate your time


Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,846
  • Location: USA
  • Karma: 523
  • "Knowledge should be shared not hidden."
Re: Netgear D6300 Add Custom Service Failed
« Reply #5 on: February 18, 2014, 12:39:26 PM »
Post a screen shot of the program trying to update the router so I can see :-)

Shane
(My weekends belong to my wife and kids, I will try my best to answer all posts daily during the work week)

(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com

PcWinTech.com Forums

Re: Netgear D6300 Add Custom Service Failed
« Reply #5 on: February 18, 2014, 12:39:26 PM »