Bookmark and Share

Author Topic: Simple Port Forwarding crashes  (Read 36993 times)

0 Members and 1 Guest are viewing this topic.

Offline luis33

  • PcWinTech Jr. Member
  • Join Date: Dec 2010
  • Posts: 3
  • Karma: 0
Simple Port Forwarding crashes
« on: December 21, 2010, 02:47:11 AM »
Hi

I've been trying to use Simple Port Forwarding and have downloaded the 3.0.15 vers from different sites (cnet, majorgeeks, etc). Have installed and unistalled and installed again but no matter what, I'll always get the "Simple Port Forwarding has encountered a problem and needs to close.  We are sorry for the inconvenience....Please tell Microsoft about this problem..bla..bla".
My system is XP SP3 with IE 8 (not the default browser but is there). What I am doing wrong. i have tried changing the installation dir but the same issue appears - all the time...I've never been past the crash screen. Should I try to install earlier ver of the program?
Apologies if someoen else has asked this question b4 but have been googling the issue to no avail.
Luis

PcWinTech.com Forums

Simple Port Forwarding crashes
« on: December 21, 2010, 02:47:11 AM »

Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,846
  • Location: USA
  • Karma: 523
  • "Knowledge should be shared not hidden."
Re: Simple Port Forwarding crashes
« Reply #1 on: December 21, 2010, 10:02:01 AM »
It shouldn't be crashing, so something else is at play.
What we need to do is test what the program does at start up.

First thing to check is the program drawing it's interface. try running" SPF - Basic UI Mode" in the start menu.
Does this help?

Another thing the program does at start up is opens the routers database
On my Shane's Toolbox page download my test mdac tool
http://www.pcwintech.com/files/shanes_toolbox/Test_MDAC.zip

Post the results for that.

And open your network connections, how many things do you have listed?

Also how far does the program make it before the crash?

Shane
(My weekends belong to my wife and kids, I will try my best to answer all posts daily during the work week)

(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com

Offline luis33

  • PcWinTech Jr. Member
  • Join Date: Dec 2010
  • Posts: 3
  • Karma: 0
Re: Simple Port Forwarding crashes
« Reply #2 on: December 21, 2010, 02:37:56 PM »
Shane,
Both SPF and the Basic UI Mode crash.
The program simple shows a small window in the miidle of the screen with :
"Please wait simple port forwarding is loading" and then straight to to the MS Windows crash window quoted b4 whith the option to Send or Don't send report to MS). i clicked in the "To see what data this error report contains click here: and the first line says 'Error signature: App name spf.exe, App ver 3.0.0.15 ModName msvbvm60.dll Mod Ver 6.0.98.2 Offset 00063f5a
My modem and router are listed Sagem Fast 1201 V2 and Lynksys WRT54GL
Downloaded the test tool - What results were you referring to? The test.mdb opens OK (I get 3 succesful replies) any other output you need?
Go to go to work now but will be back to it in a few hours to see if there are any replies.
Thanks

Luis

Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,846
  • Location: USA
  • Karma: 523
  • "Knowledge should be shared not hidden."
Re: Simple Port Forwarding crashes
« Reply #3 on: December 21, 2010, 02:54:33 PM »
msvbvm60.dll is part of the vb6 run times.

Download and install
 http://www.microsoft.com/downloads/en/details.aspx?FamilyID=bf9a24f9-b5c5-48f4-8edd-cdf2d29a79d5&displaylang=en

Let me know how it goes  :wink:

Shane
(My weekends belong to my wife and kids, I will try my best to answer all posts daily during the work week)

(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com

Offline luis33

  • PcWinTech Jr. Member
  • Join Date: Dec 2010
  • Posts: 3
  • Karma: 0
Re: Simple Port Forwarding crashes
« Reply #4 on: December 22, 2010, 05:09:01 AM »
That was it - it works now -  thanks a lot!

Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,846
  • Location: USA
  • Karma: 523
  • "Knowledge should be shared not hidden."
Re: Simple Port Forwarding crashes
« Reply #5 on: December 22, 2010, 09:43:24 AM »
I use to have the vb6 sp5 setup in the setup with simple port forwarding, but I removed it so the file size would be smaller.

Now that I know the files help I need to find a good way to make users aware of it :-)

Glad your all set!

Locking thread. :wink:

Shane
(My weekends belong to my wife and kids, I will try my best to answer all posts daily during the work week)

(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com

PcWinTech.com Forums

Re: Simple Port Forwarding crashes
« Reply #5 on: December 22, 2010, 09:43:24 AM »

 

email