PcWinTech.com Forums

Routers & Modems Forum => Port Forwarding => Topic started by: dagrin on January 02, 2019, 02:48:23 PM

Title: Port Forwarding Dilemma - ISP Change
Post by: dagrin on January 02, 2019, 02:48:23 PM
I recently lost my long time ISP and had to go with Centurylink DSL. I have the following setup as my local network:

DSL Modem/Router (ZyXel C1100Z > Cisco RVS-4000( - Local DHCP network > Local Hosts (Server Machine - Static)

I have tried every combination of settings I can think of to allow port forwarding on my local sever machine for games/FTP/RDP etc., and nothing is being forwarded as expected. I currently have the RVS4000 router in the DMZ for the DSL modem/router on as well as a static IP reservation for the same IP on the MAC address of the second router. I have the ports I want forwarded to my server machine set as they always have been, on the RVS-4000 router. They range from the standard FTP/FTPS/RDP ports, to the less common game server ports of 27015-27090 and 7777-7790. Using the Port Listener tool you provide, I can listen on a test port of 27080 and then use the Simple Port Tester on the local LAN IP of the server machine ( for both TCP and UDP ports of 27080. The simple port tester has a success on both ports, however I never see the port listener log an entry. (Attached file: Tester1.jpg)

I can use the TCP port status tool at http://www.pcwintech.com/port_test.php? with the same port of 27080 and I receive a "Server offline and cannot be reached". The Port Listener will log an entry for an attempted connection when I use the webtool. (Attached file: Listener1.jpg)

I do not run windows firewall. I have BitDefender running and have tried turning off the firewall and verifying that all ports for the server applications are allowed in both directions (in and out).

With my old internet service, I simply had the WAN input going to the RVS-4000 and the port forwarding worked flawlessly. I have even tried moving the network connection of the server machine directly to the DSL Modem/Router and both forwarding the same ports and putting that connection in the DMZ to no avail. I am starting to wonder if the DSL Router/Modem is not forwarding ports as it should. Any assistance would be most welcome.
Title: Re: Port Forwarding Dilemma - ISP Change
Post by: trpted on January 03, 2019, 06:19:48 AM
I think I know what is going on. I put this into different issues, so that it is easier to address.

** Issue one **

Here are some notes about listening:


a) If you are on Windows I point you to http://www.howtogeek.com/howto/28609/how-can-i-tell-what-is-listening-on-a-tcpip-port-in-windows/

b) If you are not on Windows (Mac, Unix/Linux), go look lookup listen on port and then your OS name using Google (or your other favorite search engine).

c) If nothing is listening any TCP ports that you check with a web based port checker, then TCP ports does not show up as open.

d) Be advised that you can not have two servers listening on the same the port on the same computer. So for example before you use an inbond-client side port checker you must make sure that uTorrent is not running - which explains on http://portforward.com/softwareguides/utorrent/utorrent.htm that they say

If uTorrent is currently open, you will need to completely close it at this time. Make sure that the green uTorrent icon is not still hiding in your notification area (next to your clock). If it is, right click on it and choose "Exit". Before moving forward to things like selecting torrents, seeders, and leachers, we need to verify that your port is open. We recommend downloading our free Open Port Check Tool to test if incoming connections are being allowed through your router on your uTorrent Listening Port

e) And generally if the program/app is running that you are trying to forward for, then the server is listening.

** Issue two **

For example with my router..

#1 With loopback set to ALL, if I enter my IP Address or Domain name that points to the Public / Route+able / True WAN IP Address - when I am behind this router, it is as remote control of the router is turned on.

#2 With loopback set to OFF/Disabled, if I enter my IP Address or Domain name that points to the Public / Route+able / True WAN IP Address - when I am behind this router, I can not connect to anything.

#3 With loopback set to Forward Only, if I enter my IP Address or Domain name that points to the Public / Route+able / True WAN IP Address - when I am behind this router, and if I am running a web server - I can connect to my web server.

It has a UI that looks something like what you see at http://victek.is-a-geek.com/virtual/tomatok26/advanced-firewall.html

#4 I have to say that not all routers support:

a) loopback

b) loopbask the same way. There are others with it is only allowed (ALL) or Filtered (OFF).

For example of All of Off, the Linksys E4200 hardware version one with Linksys official firmware (that has a UI that looks like what you see at http://ui.linksys.com/E4200/2.0.25/firewall.html )PSST/Hint also could called Internet NAT Redirection instead of Loopback.

#5 Besides a client side port checker, there is a client side Loopback/Internet NAT Redirection/Reverse NAT tester.

It is addressed at http://www.pcwintech.com/test-for-reverse-nat

** Issue three **

Your LAN IP Address of your routers should always be RFC 1918 complaint. This means that they should be in one of these three ranges:

a) to

b) to

c) to

** Issue three part b **

Since there is more than one NAT router, you could have one at and the other at