PcWinTech.com Forums

Tools & Programs By PcWinTech.com => (Program) Simple Port Forwarding => Topic started by: vivienstar on April 24, 2014, 12:17:18 PM

Title: Update Router Failed
Post by: vivienstar on April 24, 2014, 12:17:18 PM
Hello Shane, I tried your port-forwarding program and everything worked up until Update router when i update the one i made, it keeps failing saying not found. But when i try the port tester it is a success. I am bothered that error will make trouble later
Title: Re: Update Router Failed
Post by: vivienstar on April 24, 2014, 06:42:50 PM
I have windows 8 :shy:

Router: Netgear - WNR1000v3 (Netgear Firmware)
Loading Commands...
Number Of Port Forwards To Send To Router (1)
Running Commands...

(Current -  1/1)
Adding Cybergate (TCP/UDP) For Ports 99-100 To 192.168.1.1()

Running Script From Database For Selected Router
-----------------------------------------------------------------------
Step 01. nav_first_only("")
(Successful) (http://192.168.1.1/)
--------------------------------------
Step 02. set_frame_name("formframe")
--------------------------------------
Step 03. set_frame_number("2")
--------------------------------------
Step 04. wait_until_words_not_found("Checking for Firmware Updates")
(Successful - Checking for Firmware Updates Not Found On Page)
--------------------------------------
Step 05. nav("FW_forward.htm")
(Successful) (http://192.168.1.1/FW_forward.htm)
--------------------------------------
Step 06. check_if_name_exists("")
--------------------------------------
Step 07. click_button("Add")
(Failed - Object Not Found)

!ERROR! (Navigating to http://192.168.1.1/Add)
This Entry Will be Skipped.
Please Check your Router Info And Try Again.
-----------------------------------------------------------------------

--------------------------------------
Step 08. set_name("portname")
(Failed - Object Not Found)
--------------------------------------
Step 09. set_type_choices("TCP|UDP|TCP/UDP")
--------------------------------------
Step 10. set_combobox("srvtype")
(Failed - Object Not Found)
--------------------------------------
Step 11. set_start_port("port_start")
(Failed - Object Not Found)
--------------------------------------
Step 12. set_stop_port("port_end")
(Failed - Object Not Found)
--------------------------------------
Step 13. set_ip1("server_ip1")
(Failed - Object Not Found)
--------------------------------------
Step 14. set_ip2("server_ip2")
(Failed - Object Not Found)
--------------------------------------
Step 15. set_ip3("server_ip3")
(Failed - Object Not Found)
--------------------------------------
Step 16. set_ip4("server_ip4")
(Failed - Object Not Found)
--------------------------------------
Step 17. click_button("apply")
(Failed - Object Not Found)
--------------------------------------
-----------------------------------------------------------------------

Finished Adding Cybergate


-------------------DONE! (All Commands Finished)-------------------
Title: Re: Update Router Failed
Post by: Shane on April 25, 2014, 09:44:53 AM
If the port tester says the port is open then you are good :-)

But I am curious on this error

!ERROR! (Navigating to http://192.168.1.1/Add)
This Entry Will be Skipped.
Please Check your Router Info And Try Again.

The program clicked a button it didnt do a navigate, so that error shouldnt be there.

Post a screen shot of the program when it tries to update the router so i can see :-)

Shane