Bookmark and Share

Author Topic: problem forwading in tp-link tl-wr741n  (Read 19288 times)

0 Members and 1 Guest are viewing this topic.

kovian101

  • Guest
problem forwading in tp-link tl-wr741n
« on: February 18, 2010, 02:00:45 AM »
 hello i got a problem with opening the port for emule. i using dsl moden/router tp-link td-8817 and connected to a wireless router tp-link tl-wr741n. i try using the simple forwading port but it doesnt work, i also try " how to setup 2 routers" but it still doesnt work.

in virtual server in the modem whose local ip i should input the computer ip or the wireless router ip?

please help me thank you.

sorry english is not my first language
« Last Edit: February 18, 2010, 02:20:53 AM by kovian101 »

PcWinTech.com Forums

problem forwading in tp-link tl-wr741n
« on: February 18, 2010, 02:00:45 AM »

Offline Evan

  • Global Moderator
  • PcWinTech Guru
  • *****
  • Join Date: Feb 2009
  • Posts: 1,306
  • Karma: 45
Re: problem forwading in tp-link tl-wr741n
« Reply #1 on: February 18, 2010, 05:51:08 AM »
You will need to make sure that you are setting up port forwarding on the router that the computer running emule is connected to.  If that is your router that has a built in modem then you will just need to set port forwarding rules there, if your computer is connected to the second router (the wireless router) then you will have to perform an extra step.

Since you have two routers you need to forward all traffic from the modem/router (tp-link td-8817) to your wireless router (tp-link tl-wr741n).  To do this you need to look for a DMZ option in the 1st router (tp-link td-8817) and then set the DMZ to the wireless router's IP address.  After you do that then you will need to set up port forwarding as normal.

Try that and let me know how it works out.  Also if you have any errors with Simple Port Forwarding then posting the logs always help.

-Evan
About Evan:Site Admin, Tester, Editor

kovian101

  • Guest
Re: problem forwading in tp-link tl-wr741n
« Reply #2 on: February 19, 2010, 02:55:36 AM »
thank evan for the reply

 i already put my wireless router ip address into my modem dmz. then i make my wireless router to have a static ip , it use to have dynamic ip address. i try using the port forwading program again but it still doest work. i also turn off my wireless router dhcp. also i have a norton security antivirus is that effect opening the port also ? do you need to port forwarding in modem also or just the wireless router?

in the portforwading program there doesn't have my wireless router tl-rw741n so i use the tl-rw740

this the log of the port forwading for my wireless router


Router: TP-LINK - TL-WR740N (TP-LINK Firmware)
Loading Commands...
Number Of Port Forwards To Send To Router (3)
Running Commands...

(Current -  1/3)
Adding Emule(Shared)01 (TCP) For Ports 17368-17368 To 192.168.1.103()

Running Script From Database For Selected Router
-----------------------------------------------------------------------
Step 01. nav_first_only("")
(Successful) (http://xxx:xxxx@192.168.1.1/)
Step 02. set_frame_name("mainFrame")
Step 03. set_frame_number("3")
Step 04. nav("userRpm/VirtualServerRpm.htm")
(Successful) (http://xxxx:xxxx@192.168.1.1/userRpm/VirtualServerRpm.htm)
Step 05. check_if_name_exists("")
Step 06. click_button("Add New...")
(Successful)
Step 07. set_port_range("Port,0")
(Successful)
Step 08. set_ip("Ip,0")
(Successful)
Step 09. set_type_choices("TCP|UDP|ALL")
Step 10. set_combobox("Protocol,0")
(Successful)
Step 11. click_button("Save")
(Successful)
-----------------------------------------------------------------------

Finished Adding Emule(Shared)01

(Current -  2/3)
Adding Emule(Shared)02 (UDP) For Ports 62630-62630 To 192.168.1.103()

Running Script From Database For Selected Router
-----------------------------------------------------------------------
Step 01. nav_first_only("")
Step 02. set_frame_name("mainFrame")
Step 03. set_frame_number("3")
Step 04. nav("userRpm/VirtualServerRpm.htm")
(Successful) (http://xxx:xxxx@192.168.1.1/userRpm/VirtualServerRpm.htm)
Step 05. check_if_name_exists("")
Step 06. click_button("Add New...")
(Successful)
Step 07. set_port_range("Port,0")
(Successful)
Step 08. set_ip("Ip,0")
(Successful)
Step 09. set_type_choices("TCP|UDP|ALL")
Step 10. set_combobox("Protocol,0")
(Successful)
Step 11. click_button("Save")
(Successful)
-----------------------------------------------------------------------

Finished Adding Emule(Shared)02

(Current -  3/3)
Adding uTorrent01 (TCP) For Ports 11565-11565 To 192.168.1.210()

Running Script From Database For Selected Router
-----------------------------------------------------------------------
Step 01. nav_first_only("")
Step 02. set_frame_name("mainFrame")
Step 03. set_frame_number("3")
Step 04. nav("userRpm/VirtualServerRpm.htm")
(Successful) (http://xxxx:xxxx@192.168.1.1/userRpm/VirtualServerRpm.htm)
Step 05. check_if_name_exists("")
Step 06. click_button("Add New...")
(Successful)
Step 07. set_port_range("Port,0")
(Successful)
Step 08. set_ip("Ip,0")
(Successful)
Step 09. set_type_choices("TCP|UDP|ALL")
Step 10. set_combobox("Protocol,0")
(Successful)
Step 11. click_button("Save")
(Successful)
-----------------------------------------------------------------------

Finished Adding uTorrent01


-------------------DONE! (All Commands Finished)-----------------
« Last Edit: February 19, 2010, 03:04:22 AM by kovian101 »

Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,366
  • Location: USA
  • Karma: 489
  • "Knowledge should be shared not hidden."
Re: problem forwading in tp-link tl-wr741n
« Reply #3 on: February 19, 2010, 08:22:44 AM »
The script looks like it worked fine.
It is possible Norton is blocking the ports (If you have its firewall running) I personally cant stand Norton. There is free and better alternatives if your ever interested. For firewall you can use comodo firewall and for antivirus you can use avira. Both free and better than Norton.

But besides that lets try to fig out whats going on.
Of course make sure to look over everything on here
http://www.pcwintech.com/common-problems-fixes-port-forwarding

And some screen shots will help a ton as well. a screen shot of the port forwarding page and of the main window of my program.

Also log into the first router, find its WAN/Internet IP address. Does it match the IP that shows up on the port tester page?

Shane
(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com

kovian101

  • Guest
Re: problem forwading in tp-link tl-wr741n
« Reply #4 on: February 19, 2010, 11:06:45 AM »
just now i try to turn off the norton firewall it still doesnt work
so i will give u the screen shoot from the wireless router and the modem/router

thank you for the help

http://img704.imageshack.us/i/adslmodemdmz.jpg/
http://img192.imageshack.us/i/wireless1.jpg/
http://img28.imageshack.us/i/wirelessw.jpg/
http://img148.imageshack.us/i/portforwarding.jpg/

budi

« Last Edit: February 19, 2010, 06:28:22 PM by kovian101 »

Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,366
  • Location: USA
  • Karma: 489
  • "Knowledge should be shared not hidden."
Re: problem forwading in tp-link tl-wr741n
« Reply #5 on: February 19, 2010, 12:00:50 PM »
I got page not found on the pics, can you double check?

Shane
(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com


Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,366
  • Location: USA
  • Karma: 489
  • "Knowledge should be shared not hidden."
Re: problem forwading in tp-link tl-wr741n
« Reply #7 on: February 20, 2010, 05:50:49 AM »
Gotta love screen shots :artist: I see the problem. You have DMZ setup in both routers to the same IP.

it goes like this
Internet --> Router 1 --> Router 2 --> Computer

So in router 1 you will enable DMZ, then put in 192.168.0.6 (Which by the screen shots is the WAN IP of Router 2)
Now in router 2 turn off DMZ.
In router 2 setup port forwarding like normal. Make sure the port forwarding rules are pointed to the right Ip address (The local IP of your computer)

Then run the port tester  :wink:

Shane
(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com

kovian101

  • Guest
Re: problem forwading in tp-link tl-wr741n
« Reply #8 on: February 20, 2010, 06:26:26 PM »
it worked.

thank you shane for your help.

i really grateful.

budi

Offline Shane

  • Top Geek, err uh Dog.
  • PcWinTech Administrator
  • PcWinTech Guru
  • *******
  • Join Date: Jul 2008
  • Posts: 16,366
  • Location: USA
  • Karma: 489
  • "Knowledge should be shared not hidden."
Re: problem forwading in tp-link tl-wr741n
« Reply #9 on: February 20, 2010, 06:27:48 PM »
Good to hear  :wink:

Locking thread.

Shane
(About Shane)
Site Owner, Top Admin, Lead Programmer, Wife & 5 kids, Needs a lot more coffee.

When people ask "Why fix what isn't broken?" I reply "To make it better."
"Only a life lived for others is a life worthwhile"
Honor & Respect is all that matters.

Owner & Programmer of: www.pcwintech.com & www.tweaking.com

PcWinTech.com Forums

Re: problem forwading in tp-link tl-wr741n
« Reply #9 on: February 20, 2010, 06:27:48 PM »

 

anything